eclipse plugin

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

eclipse plugin

tarun3kumar

hello,
I am using eclipse 3.2 and testng plugin 5.5. Java version is 1.6.
I successfully installed testng plugin.
my junit test cases are working fine with testng plugin.
But when i am trying to use annotations it is telling that :
Syntax error, annotations are only available is source level is 5.0.
I don't understand the exact meaning of this error.
What i have to do to solve this error.
Please help me....

Regards,
ads
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.opensymphony.com/thread.jspa?threadID=77773&messageID=142350#142350


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "testng-users" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/testng-users?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: eclipse plugin

Paul Cantrell-3

This sounds like an Eclipse issue, not a TestNG issue. You need to
change your project settings in Eclipse so that the compiler is using
source level 1.5.

Go to Project menu -> Properties -> Java Compiler. Choose "Enable
project specific settings" if it is not already selected, then set the
"Compiler compliance setting" to 5.0.

Cheers,

Paul

On Apr 17, 1:05 am, ads <[hidden email]> wrote:

> hello,
> I am using eclipse 3.2 and testng plugin 5.5. Java version is 1.6.
> I successfully installed testng plugin.
> my junit test cases are working fine with testng plugin.
> But when i am trying to use annotations it is telling that :
> Syntax error, annotations are only available is source level is 5.0.
> I don't understand the exact meaning of this error.
> What i have to do to solve this error.
> Please help me....
>
> Regards,
> ads
> ---------------------------------------------------------------------
> Posted via Jive Forumshttp://forums.opensymphony.com/thread.jspa?threadID=77773&messageID=1...


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "testng-users" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/testng-users?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: eclipse plugin

tarun3kumar

Thanks a lot paul. I am trying to solve this problem from 2 days.
Once again thanks.

Regards,
Ads
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.opensymphony.com/thread.jspa?threadID=77773&messageID=142356#142356


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "testng-users" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/testng-users?hl=en
-~----------~----~----~----~------~----~------~--~---