eclipse plugin error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

eclipse plugin error

tarun3kumar

Hello,
I am using eclipse 3.2, testng eclipse plugin 5.5,junit 4.1 and java 1.6. I am running junit test cases using testng. I am making junit flag true for that. from command prompt it is working fine. But when i run the same xml file from testng eclipse plugin i ma getting following error :

[Parser] Running:
  C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\TestProject\testng2.xml

org.testng.TestNGException:
Failure in JUnit mode for class TestNGCase: could not create/run JUnit test suite:
cannot retrieve JUnit method
        at org.testng.junit.JUnitTestRunner.runFailed(JUnitTestRunner.java:231)
        at org.testng.junit.JUnitTestRunner.start(JUnitTestRunner.java:224)
        at org.testng.junit.JUnitTestRunner.run(JUnitTestRunner.java:205)
        at org.testng.TestRunner$1.run(TestRunner.java:535)
        at org.testng.TestRunner.runWorkers(TestRunner.java:673)
        at org.testng.TestRunner.privateRunJUnit(TestRunner.java:547)
        at org.testng.TestRunner.run(TestRunner.java:477)
        at org.testng.SuiteRunner.runTest(SuiteRunner.java:278)
        at org.testng.SuiteRunner.runSequentially(SuiteRunner.java:273)
        at org.testng.SuiteRunner.privateRun(SuiteRunner.java:253)
        at org.testng.SuiteRunner.run(SuiteRunner.java:168)
        at org.testng.TestNG.createAndRunSuiteRunners(TestNG.java:987)
        at org.testng.TestNG.runSuitesLocally(TestNG.java:951)
        at org.testng.TestNG.run(TestNG.java:719)
        at org.testng.remote.RemoteTestNG.run(RemoteTestNG.java:73)
        at org.testng.remote.RemoteTestNG.main(RemoteTestNG.java:122)

===============================================
suite
Total tests run: 0, Failures: 0, Skips: 0
===============================================

Can anybody tell me what is wrong with it????
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.opensymphony.com/thread.jspa?threadID=77796&messageID=142398#142398


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "testng-users" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/testng-users?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: eclipse plugin error

Alexandru Popescu ☀

TestNG does not support running JUnit 4.x tests, but only JUnit 3.x. I
think this is what you are seeing.

./alex
--
.w( the_mindstorm )p.
  TestNG co-founder
EclipseTestNG Creator


On 4/17/07, ads <[hidden email]> wrote:

>
> Hello,
> I am using eclipse 3.2, testng eclipse plugin 5.5,junit 4.1 and java 1.6. I am running junit test cases using testng. I am making junit flag true for that. from command prompt it is working fine. But when i run the same xml file from testng eclipse plugin i ma getting following error :
>
> [Parser] Running:
>   C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\TestProject\testng2.xml
>
> org.testng.TestNGException:
> Failure in JUnit mode for class TestNGCase: could not create/run JUnit test suite:
> cannot retrieve JUnit method
>         at org.testng.junit.JUnitTestRunner.runFailed(JUnitTestRunner.java:231)
>         at org.testng.junit.JUnitTestRunner.start(JUnitTestRunner.java:224)
>         at org.testng.junit.JUnitTestRunner.run(JUnitTestRunner.java:205)
>         at org.testng.TestRunner$1.run(TestRunner.java:535)
>         at org.testng.TestRunner.runWorkers(TestRunner.java:673)
>         at org.testng.TestRunner.privateRunJUnit(TestRunner.java:547)
>         at org.testng.TestRunner.run(TestRunner.java:477)
>         at org.testng.SuiteRunner.runTest(SuiteRunner.java:278)
>         at org.testng.SuiteRunner.runSequentially(SuiteRunner.java:273)
>         at org.testng.SuiteRunner.privateRun(SuiteRunner.java:253)
>         at org.testng.SuiteRunner.run(SuiteRunner.java:168)
>         at org.testng.TestNG.createAndRunSuiteRunners(TestNG.java:987)
>         at org.testng.TestNG.runSuitesLocally(TestNG.java:951)
>         at org.testng.TestNG.run(TestNG.java:719)
>         at org.testng.remote.RemoteTestNG.run(RemoteTestNG.java:73)
>         at org.testng.remote.RemoteTestNG.main(RemoteTestNG.java:122)
>
> ===============================================
> suite
> Total tests run: 0, Failures: 0, Skips: 0
> ===============================================
>
> Can anybody tell me what is wrong with it????
> ---------------------------------------------------------------------
> Posted via Jive Forums
> http://forums.opensymphony.com/thread.jspa?threadID=77796&messageID=142398#142398
>
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "testng-users" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/testng-users?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply | Threaded
Open this post in threaded view
|

Re: eclipse plugin error

tarun3kumar
In reply to this post by tarun3kumar

Hello,
               I got the solution. Sorry for disturbance.

Regards,
ads
---------------------------------------------------------------------
Posted via Jive Forums
http://forums.opensymphony.com/thread.jspa?threadID=77796&messageID=142407#142407


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "testng-users" group.
To post to this group, send email to [hidden email]
To unsubscribe from this group, send email to [hidden email]
For more options, visit this group at http://groups.google.com/group/testng-users?hl=en
-~----------~----~----~----~------~----~------~--~---