TestNG parallel execution on AMD A8 machines not working

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

TestNG parallel execution on AMD A8 machines not working

Ravi Pratap

I am trying to run following test in parallel using testNG. The test run in parallel on Intel processors but on AMD processors they are running in sequential order.

testng.xml :

<suite name="Suite" parallel="tests" thread-count="2">
     <test name="Test1">    
        <parameter name="RowNoStart" value="0"></parameter>
        <parameter name="RowNoEnd" value="10"></parameter>  
            <classes>
                <class name="com.tests.TestClass1"></class>
            </classes>      
    </test> 
     <test name="Test2">    
        <parameter name="RowNoStart" value="11"></parameter>
        <parameter name="RowNoEnd" value="12"></parameter>  
            <classes>
                <class name="com.tests.TestClass2"></class>
            </classes>      
    </test>
</suite>

Please let me know how can I resolve this issue?

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: TestNG parallel execution on AMD A8 machines not working

Todd Bradley-2
Wow, I never would've expected the CPU vendor to have an effect on TestNG. Are you sure you're using the same JDK in both cases?

On Tue, Jan 16, 2018 at 10:29 PM, Ravi Pratap <[hidden email]> wrote:

I am trying to run following test in parallel using testNG. The test run in parallel on Intel processors but on AMD processors they are running in sequential order.

testng.xml :

<suite name="Suite" parallel="tests" thread-count="2">
     <test name="Test1">    
        <parameter name="RowNoStart" value="0"></parameter>
        <parameter name="RowNoEnd" value="10"></parameter>  
            <classes>
                <class name="com.tests.TestClass1"></class>
            </classes>      
    </test> 
     <test name="Test2">    
        <parameter name="RowNoStart" value="11"></parameter>
        <parameter name="RowNoEnd" value="12"></parameter>  
            <classes>
                <class name="com.tests.TestClass2"></class>
            </classes>      
    </test>
</suite>

Please let me know how can I resolve this issue?

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: TestNG parallel execution on AMD A8 machines not working

Krishnan Mahadevan

Ravi,

What version of TestNG are you working with? If its TestNG 6.13.1 then there was a bug related to this (https://github.com/cbeust/testng/issues/1636) which was fixed in the latest TestNG version [6.14-SNAPSHOT which is yet to be released).

Can you please try this work-around and see if it helps in the mean-time?

 

Thanks & Regards

Krishnan Mahadevan

 

"All the desirable things in life are either illegal, expensive, fattening or in love with someone else!"

My Scribblings @ http://wakened-cognition.blogspot.com/

My Technical Scribbings @ http://rationaleemotions.wordpress.com/

 

From: <[hidden email]> on behalf of Todd Bradley <[hidden email]>
Reply-To: <[hidden email]>
Date: Wednesday, January 17, 2018 at 10:57 PM
To: <[hidden email]>
Subject: Re: [testng-users] TestNG parallel execution on AMD A8 machines not working

 

Wow, I never would've expected the CPU vendor to have an effect on TestNG. Are you sure you're using the same JDK in both cases?

 

On Tue, Jan 16, 2018 at 10:29 PM, Ravi Pratap <[hidden email]> wrote:

I am trying to run following test in parallel using testNG. The test run in parallel on Intel processors but on AMD processors they are running in sequential order.

testng.xml :

<suite name="Suite" parallel="tests" thread-count="2">
     <test name="Test1">    
        <parameter name="RowNoStart" value="0"></parameter>
        <parameter name="RowNoEnd" value="10"></parameter>  
            <classes>
                <class name="com.tests.TestClass1"></class>
            </classes>      
    </test> 
     <test name="Test2">    
        <parameter name="RowNoStart" value="11"></parameter>
        <parameter name="RowNoEnd" value="12"></parameter>  
            <classes>
                <class name="com.tests.TestClass2"></class>
            </classes>      
    </test>
</suite>

Please let me know how can I resolve this issue?

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.

 

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.