Allure reporting: html file is not generated- Testng, pom.xml

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Allure reporting: html file is not generated- Testng, pom.xml

garvitagirotraev
Hi,

My site folder is blank after test run, xml file is generated in allure-results folder. Earlier, html file was being generated as allure-maven-plugin.html under site folder. But now this folder is blank. Below is my pom.xml, can anyone please help me knowing what i need to correct in this to get html file:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
         <modelVersion>4.0.0</modelVersion>

           <groupId>com.testtest</groupId>
           <artifactId>itests</artifactId>
           <version>0.1-SNAPSHOT</version>
           <properties>
            <allure.version>2.6</allure.version>
           <aspectj.version>1.8.10</aspectj.version>
    </properties>
     <dependencies>
      <!-- https://mvnrepository.com/artifact/io.qameta.allure/allure-testng -->
        
       <dependency>
            <groupId>ru.yandex.qatools.allure</groupId>
            <artifactId>allure-testng-adaptor</artifactId>
            <version>1.5.3</version>
            <exclusions>
                <exclusion>
                    <groupId>junit</groupId>
                    <artifactId>junit</artifactId>
                </exclusion>
            </exclusions>
        </dependency>
    
        <dependency>
            <groupId>org.testng</groupId>
            <artifactId>testng</artifactId>
            <version>6.11</version>
            <scope>test</scope>
        </dependency>

        <dependency>
            <groupId>org.seleniumhq.selenium</groupId>
            <artifactId>selenium-java</artifactId>
            <version>3.4.0</version>
        </dependency>
        <dependency>
            <groupId>org.seleniumhq.selenium</groupId>
            <artifactId>selenium-server</artifactId>
            <version>3.4.0</version>
        </dependency>
        <dependency>
           <groupId>org.apache.poi</groupId>
           <artifactId>poi</artifactId>
           <version>3.16</version>
     </dependency> 
     <dependency>
        <groupId>org.apache.poi</groupId>
        <artifactId>poi-ooxml</artifactId>
        <version>3.16</version>
    </dependency>
    </dependencies>
     
    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.5.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                </configuration>
            </plugin>
            <plugin>
    <groupId>io.qameta.allure</groupId>
    <artifactId>allure-maven</artifactId>
    <version>2.8</version>
</plugin>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-surefire-plugin</artifactId>
                <version>2.20</version>
                <configuration>
                <testFailureIgnore>true</testFailureIgnore>
                <argLine>
                    -javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"
                </argLine>
                <properties>
                   <property>
                       <name>listener</name>
                        <value>ru.yandex.qatools.allure.junit.AllureRunListener</value>
                    </property>
                   </properties>
                        <suiteXmlFiles>
                        <suiteXmlFile>testng.xml</suiteXmlFile>
                    </suiteXmlFiles>
                </configuration>
                <dependencies>
                <dependency>
                    <groupId>org.aspectj</groupId>
                    <artifactId>aspectjweaver</artifactId>
                    <version>1.8.10</version>
                </dependency>
            </dependencies>
            </plugin>
        </plugins>
    </build>
    
    <reporting>
    <excludeDefaults>true</excludeDefaults>
    <plugins>
        <plugin>
             <groupId>ru.yandex.qatools.allure</groupId>
              <artifactId>allure-maven-plugin</artifactId>
                <version>2.6</version>
               <configuration>
                    <outputDirectory>${basedir}/target/allure-reports/</outputDirectory>
                    <allureResultsDirectory>${basedir}/target/allure-results</allureResultsDirectory>
            </configuration>
        </plugin>
           </plugins>
                   
</reporting>
</project>


Thanks !!

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Allure reporting: html file is not generated- Testng, pom.xml

TotalQA
Hi,

Please find the Step-by-Step implementation of Maven,Testng,Allure Reporting with steps.

Thanks,

On Thursday, September 21, 2017 at 3:36:10 PM UTC+5:30, [hidden email] wrote:
Hi,

My site folder is blank after test run, xml file is generated in allure-results folder. Earlier, html file was being generated as allure-maven-plugin.html under site folder. But now this folder is blank. Below is my pom.xml, can anyone please help me knowing what i need to correct in this to get html file:

<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="<a href="http://maven.apache.org/POM/4.0.0" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fmaven.apache.org%2FPOM%2F4.0.0\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHniHazh___yjkHSI3PBdhuZVHNgw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fmaven.apache.org%2FPOM%2F4.0.0\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHniHazh___yjkHSI3PBdhuZVHNgw&#39;;return true;">http://maven.apache.org/POM/4.0.0"
         xmlns:xsi="<a href="http://www.w3.org/2001/XMLSchema-instance" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.w3.org%2F2001%2FXMLSchema-instance\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFERp6A_kcvqihMCKJ7EHX8O14vIA&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fwww.w3.org%2F2001%2FXMLSchema-instance\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFERp6A_kcvqihMCKJ7EHX8O14vIA&#39;;return true;">http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="<a href="http://maven.apache.org/POM/4.0.0" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fmaven.apache.org%2FPOM%2F4.0.0\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHniHazh___yjkHSI3PBdhuZVHNgw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fmaven.apache.org%2FPOM%2F4.0.0\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHniHazh___yjkHSI3PBdhuZVHNgw&#39;;return true;">http://maven.apache.org/POM/4.0.0 <a href="http://maven.apache.org/xsd/maven-4.0.0.xsd" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fmaven.apache.org%2Fxsd%2Fmaven-4.0.0.xsd\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFooKp_ndR1_GzTUBHrZ7dw50YoEw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fmaven.apache.org%2Fxsd%2Fmaven-4.0.0.xsd\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFooKp_ndR1_GzTUBHrZ7dw50YoEw&#39;;return true;">http://maven.apache.org/xsd/maven-4.0.0.xsd">
         <modelVersion>4.0.0</modelVersion>

           <groupId>com.testtest</groupId>
           <artifactId>itests</artifactId>
           <version>0.1-SNAPSHOT</version>
           <properties>
            <allure.version>2.6</allure.version>
           <aspectj.version>1.8.10</aspectj.version>
    </properties>
     <dependencies>
      <!-- <a href="https://mvnrepository.com/artifact/io.qameta.allure/allure-testng" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fmvnrepository.com%2Fartifact%2Fio.qameta.allure%2Fallure-testng\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEi6BJZq7WUeqH9WQG1H55ERcHJnw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fmvnrepository.com%2Fartifact%2Fio.qameta.allure%2Fallure-testng\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEi6BJZq7WUeqH9WQG1H55ERcHJnw&#39;;return true;">https://mvnrepository.com/artifact/io.qameta.allure/allure-testng -->
        
       <dependency>
            <groupId>ru.yandex.qatools.allure</groupId>
            <artifactId>allure-testng-adaptor</artifactId>
            <version>1.5.3</version>
            <exclusions>
                <exclusion>
                    <groupId>junit</groupId>
                    <artifactId>junit</artifactId>
                </exclusion>
            </exclusions>
        </dependency>
    
        <dependency>
            <groupId>org.testng</groupId>
            <artifactId>testng</artifactId>
            <version>6.11</version>
            <scope>test</scope>
        </dependency>

        <dependency>
            <groupId>org.seleniumhq.selenium</groupId>
            <artifactId>selenium-java</artifactId>
            <version>3.4.0</version>
        </dependency>
        <dependency>
            <groupId>org.seleniumhq.selenium</groupId>
            <artifactId>selenium-server</artifactId>
            <version>3.4.0</version>
        </dependency>
        <dependency>
           <groupId>org.apache.poi</groupId>
           <artifactId>poi</artifactId>
           <version>3.16</version>
     </dependency> 
     <dependency>
        <groupId>org.apache.poi</groupId>
        <artifactId>poi-ooxml</artifactId>
        <version>3.16</version>
    </dependency>
    </dependencies>
     
    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.5.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                </configuration>
            </plugin>
            <plugin>
    <groupId>io.qameta.allure</groupId>
    <artifactId>allure-maven</artifactId>
    <version>2.8</version>
</plugin>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-surefire-plugin</artifactId>
                <version>2.20</version>
                <configuration>
                <testFailureIgnore>true</testFailureIgnore>
                <argLine>
                    -javaagent:"${settings.localRepository}/org/aspectj/aspectjweaver/${aspectj.version}/aspectjweaver-${aspectj.version}.jar"
                </argLine>
                <properties>
                   <property>
                       <name>listener</name>
                        <value>ru.yandex.qatools.allure.junit.AllureRunListener</value>
                    </property>
                   </properties>
                        <suiteXmlFiles>
                        <suiteXmlFile>testng.xml</suiteXmlFile>
                    </suiteXmlFiles>
                </configuration>
                <dependencies>
                <dependency>
                    <groupId>org.aspectj</groupId>
                    <artifactId>aspectjweaver</artifactId>
                    <version>1.8.10</version>
                </dependency>
            </dependencies>
            </plugin>
        </plugins>
    </build>
    
    <reporting>
    <excludeDefaults>true</excludeDefaults>
    <plugins>
        <plugin>
             <groupId>ru.yandex.qatools.allure</groupId>
              <artifactId>allure-maven-plugin</artifactId>
                <version>2.6</version>
               <configuration>
                    <outputDirectory>${basedir}/target/allure-reports/</outputDirectory>
                    <allureResultsDirectory>${basedir}/target/allure-results</allureResultsDirectory>
            </configuration>
        </plugin>
           </plugins>
                   
</reporting>
</project>


Thanks !!

--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/testng-users.
For more options, visit https://groups.google.com/d/optout.